Tags: | Categories: Blog Posted by admin on 3/9/2009 5:57 PM | Comments (1)

Finally Scott Guthrie released the news, was waiting to post my review.

Friday night I installed Visual Studio 2008 SP1 (Beta) on my wife's computer and was pretty smooth. I looking to fix the issue on VS2008 and Vista that many of us is experiencing, the (Not Responding) label once in a while when you try to switch from code to designer.

A quick read into the feed roll you’ll find at least 20 posts linking ScottGu about the VS2008 SP1 Beta, however I don’t see many people installing it. Are people a little put off by the huge set of instructions to install the Service Pack? Are we waiting for others to let us know is ok?  

Downloads
VS 2008 SP1 : http://download.microsoft.com/download/7/3/8/7382EA08-4DD6-4134-9B92-8585A5B07973/VS90sp1-KB945140-ENU.exe 

Also 3.5 need a new service pack
.NET 3.5 SP1 : http://download.microsoft.com/download/8/f/c/8fc1fe13-55de-4bf5-b43e-375daf01452e/dotNetFx35setup.exe
Express 2008 with SP1:
http://download.microsoft.com/download/F/E/7/FE754BA4-140B-413C-933F-8D35FB150F12/vbsetup.exe
http://download.microsoft.com/download/F/E/7/FE754BA4-140B-413C-933F-8D35FB150F12/vcsetup.exe
http://download.microsoft.com/download/F/E/7/FE754BA4-140B-413C-933F-8D35FB150F12/vcssetup.exe
http://download.microsoft.com/download/F/E/7/FE754BA4-140B-413C-933F-8D35FB150F12/vnssetup.exe
TFS 2008 SP1: http://download.microsoft.com/download/a/e/2/ae2eb0ff-e687-4221-9c3e-9165a942bc1c/TFS90sp1-KB949786.exe

 

Some issues you may encounter on the way.

Make sure you install VS2008 SP1 before Framework 3.5 SP1.

Installation of Visual Studio 2008 SP1 Beta fails when .NET Framework 3.5 Client Beta 1 is already installed on the computer.

To resolve this issue:

  1. Open Add or Remove Programs.
  2. Uninstall "Microsoft .NET Framework 3.5 Client Beta 1".
  3. Uninstall "Microsoft .NET Framework 3.0 Client Beta 1".
  4. Uninstall "Microsoft .NET Framework 2.0 Client Beta".

 

Visual Studio 2008 SP1 cannot be installed when SilverLight Tools is installed on the computer.

Visual Studio 2008 SP1 Beta cannot be installed if Silverlight Tools is already installed. The following message will appear if you attempt to install:
Microsoft Visual Studio 2008 SP1 (Beta) does not apply, or is blocked by another condition on your system. Please click the link below for more details.
If you want to install Visual Studio 2008 SP1, you must first uninstall Silverlight Tools.

To resolve this issue:

For Vista or later:

  1. Open Add or Remove Programs.
  2. Uninstall Silverlight Tools Beta for Visual Studio 2008.
  3. Click 'View installed updates' in the task bar on the left.
  4. Remove KB949325 (listed under the version of Visual Studio 2008).

 

Astoria comes out with SP1

Pablo Castro released the news: The ADO.NET Data Services Framework (Astoria) and the ADO.NET Entity Framework will be shipping as part of .NET 3.5 SP1

 

ASP.NET MVC and SP1 Beta

Phil Haack explains how SP1 will affect the MVC preview 2, no affect if you are running Preview 3. In another words, if you can upgrade your MVC before installing SP1 Beta.  NET 3.5 SP1 Beta and Its Effect on MVC 

 

Related Links

Problems installing VS2008 Service Pack 1 with Silverlight

Brad Abrams Tutorial to install Service Pack 1

ScottGu's post about VS 2008 Service Pack 1

Visual Studio 2008 and .NET FX 3.5 SP1 Beta available now

VS2008 and .Net 3.5 SP1 Beta - Should You Fear This Release?

 

Cheers

Al

Follow me at GeoTwitter | Check Geo Twitter

blog comments powered by Disqus